AirSystemData Class


Air System Data Class

Represents the data and parameter of analytical air system.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical AirSystemData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AirSystemData : IDisposable

The AirSystemData type exposes the following members.

Properties
Name Description
Public property AirFanType The fan type.
Public property ChilledWaterLoopId The chilled water loop used for the chilled water option of cooling coil.
Public property CoolingCoilType The cooling coil type. Note this property change would reset the chilled water loop.
Public property HeatExchangerType The type of heat exchanger.
Public property HeatingCoilType The heating coil type. Note this property change would reset the heating water loop.
Public property HeatingHotWaterLoopId The water loop element id for the hot-water heating coil.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PreheatCoilType The preheat coil type. Note this property change would reset the preheat water loop.
Public property PreheatHotWaterLoopId The water loop element id for the hot-water preheat coil.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AirSystemData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also