IsCurveInsideHostBoundaries Method


Line Load Is Curve Inside Host Boundaries Method

Indicates if the curve is inside panel's boundaries or on panel's edges or if the curve is on the member's curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsCurveInsideHostBoundaries(
	Document doc,
	ElementId hostId,
	Curve curve
)

Parameters

doc Document
The document containing both the host and the line load.
hostId ElementId
The id of the analytical element that is about to host a line load.
curve Curve
Curve to be checked.

Return Value

Boolean
True if a line load can be placed on the input host id
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also