AssemblyViewUtils Class


Assembly View Utils Class

Utilities that provide capabilities related to assembly view creation and validation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB AssemblyViewUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class AssemblyViewUtils

The AssemblyViewUtils type exposes the following members.

Methods
Name Description
Public method Static member AcquireAssemblyViews Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Public method Static member Create3DOrthographic(Document, ElementId) Creates a new orthographic 3D assembly view for the assembly instance.
Public method Static member Create3DOrthographic(Document, ElementId, ElementId, Boolean) Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
Public method Static member CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) Creates a new detail section assembly view for the assembly instance.
Public method Static member CreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) Creates a new detail section assembly view for the assembly instance.
Public method Static member CreateMaterialTakeoff(Document, ElementId) Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Public method Static member CreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Public method Static member CreatePartList(Document, ElementId) Creates a new part list multicategory schedule assembly view for the assembly instance.
Public method Static member CreatePartList(Document, ElementId, ElementId, Boolean) Creates a new part list multicategory schedule assembly view for the assembly instance.
Public method Static member CreateSheet Creates a new sheet assembly view for the assembly instance.
Public method Static member CreateSingleCategorySchedule(Document, ElementId, ElementId) Creates a new single-category schedule assembly view for the assembly instance.
Public method Static member CreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) Creates a new single-category schedule assembly view for the assembly instance.
Top
See Also