BuiltInFailures.StairRampFailures Class


Built In Failures Stair Ramp Failures Class

Failures about StairRamp.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures StairRampFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class StairRampFailures

The BuiltInFailures StairRampFailures type exposes the following members.

Properties
Name Description
Public property Static member ActualRiserHeightChanged The actual riser height for one or more stairs violates the maximum set in the type.
Public property Static member AntiparallelRampRisers Riser lines are parallel but not collinear. Can't build Run between these Risers.
Public property Static member AntiparallelRampRisersError Riser lines are parallel but not collinear. Can't build Run between these Risers.
Public property Static member ArcRunRadiusTooSmall Can't create Run. Run radius is too small.
Public property Static member ArcRunWidthTooLongFailure Arc run width is too long.
Public property Static member AutomaticLandingConvertedToSketchedLandingWarning Some run(s) are deleted, so automatic landing is converted to sketched landing.
Public property Static member BadBalustersPerTread Number of Balusters per Tread must be an integer greater than zero.
Public property Static member BadFillingSpacing Spacing for Excess Length Fill is too small.
Public property Static member BadRailings Can't create Railings.
Public property Static member BadRailingsError Can't create Railings.
Public property Static member BadRailProfile One or more Profile Loops are invalid, probably because of self-intersection.
Public property Static member BadTreadRiserProfile Tread/Riser profile is invalid.
Public property Static member BalustersTooClose Baluster Separation must be equal to or greater than the Baluster widths.
Public property Static member BalustersTooCloseAbsolute Baluster Separation is too small.
Public property Static member BalusterUpsideDown Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
Public property Static member CannotAlignSupportOnPosts Cannot align the support on the posts.
Public property Static member CannotComputeRailElevation Can't compute elevation profile for one or more Rails
Public property Static member CannotCreateBaluster Can't create Balusters for given Width and Height.
Public property Static member CannotCreateBalusterPatterns Can't create Baluster Patterns for Railings
Public property Static member CannotCreateCornerBalusters Can't create corner Baluster
Public property Static member CannotCreateLandingStringer Can't create stringer at landing.
Public property Static member CannotCreateMiddleStringer Can't create one or more Middle Stringers.
Public property Static member CannotCreateMonolithicStairs Can't make monolithic Stairs.
Public property Static member CannotCreateNosing Can't create nosing on one or more treads.
Public property Static member CannotCreateOneOrMoreBaluster Can't create one or more Balusters
Public property Static member CannotCreateOneOrMoreTreads Can't create geometry for one or more treads.
Public property Static member CannotCreateOpenMiddleStringers Can't cut open/middle stringers geometry.
Public property Static member CannotCreateRail Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
Public property Static member CannotCreateRailGeom Can't create geometry for one or more Rails
Public property Static member CannotCreateRailWarn Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
Public property Static member CannotCreateRiser Can't create geometry for one or more risers.
Public property Static member CannotCreateSideStringer Can't create one or more Side Stringers.
Public property Static member CannotCreateStairForLevelOverlapping Some of the multistory stairs couldn't be created due to the overlapped levels.
Public property Static member CannotCreateStringers Can't create stringers geometry.
Public property Static member CannotDrawStairs Can't make stairs
Public property Static member CannotDrawStairsError Can't make stairs
Public property Static member CannotEndWithZeroRiser Can't end Stairs with Riser because Riser Thickness is too small.
Public property Static member CannotGenerateFaces Couldn't generate surfaces for stairs.
Public property Static member CannotGenerateFacesError Couldn't generate surfaces for stairs.
Public property Static member CannotGenerateRamp Couldn't generate surfaces for ramp.
Public property Static member CannotGenerateRampError Couldn't generate surfaces for ramp.
Public property Static member CannotMakeLanding Can't make landing.
Public property Static member CannotOffsetBoundary Can't create Boundary as an offset of Run Curve
Public property Static member CannotOffsetRail Can't create one or more Rails with desired offset
Public property Static member CannotPlaceBalusterOffset Can't place Balusters and/or Rails with desired offset
Public property Static member CannotPlaceBalusterPatterns Can't place Baluster Patterns
Public property Static member CannotPlaceRailingOnStringerWarning Railing is placed on tread because there is no stringer.
Public property Static member CannotProcessInStairsSketchEditMode Cannot process when stair(s) in sketch edit mode.
Public property Static member CannotSplitRailingWithExtensions Railings with extensions cannot be split.
Public property Static member ContinuousRailFilletCreationError Cannot create specified fillet at rail path corner.
Public property Static member ContinuousRailFilletCreationParallel Cannot create specified fillet at rail path corner because of the curves are already smoothed.
Public property Static member ContinuousRailFilletCreationWarning Cannot create specified fillet at rail path corner.
Public property Static member ContinuousRailGometryCreationFailure Cannot create the continuous rail geometry.
Public property Static member ContinuousRailNotContinuous The rail is non-continuous.
Public property Static member ContinuousRailSupportPlacementFailure Cannot place the supports along the rail path.
Public property Static member ContinuousRailTransitionFailure Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
Public property Static member ExtendBelowBaseGreaterThanLandingBaseElevation Extend Below Base needs to be less than Landing Base Elevation.
Public property Static member ExtendBelowBaseGreaterThanRunTopElevation Extend Below Base needs to be less than Run Top Elevation.
Public property Static member FailToReOrientSketchCurvesFailure Failed to orient sketch curves.
Public property Static member HeightOfRunIsTooSmall Height of run is too small.
Public property Static member IntermediateLandingHigherThanTopRunFailure Run is reversed.
Public property Static member InvalidBalustersPattern Invalid Balusters Pattern
Public property Static member InvalidLocationLineJustificationFailure Modify the location justification to a invalid value.
Public property Static member InvalidParameters Stairs run or landing has invalid parameter(s).
Public property Static member InvalidRailProfile Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
Public property Static member InvalidStairsPathFailure Invalid stairs path provided.
Public property Static member InvalidStartLevel The start level and end level for this staircase must be at different elevations.
Public property Static member InvalidStartLevelRamp The start level and end level for this ramp must be at different elevations.
Public property Static member LandingDepthIsLessThanRunWidthWarning Landing depth is less than run width.
Public property Static member LandingHeightUnderStairsBottom Cannot make landing because height of landing is equal or less than to bottom height of the stair.
Public property Static member LandingShapeHandleOnPinnedRunFailure Cannot Drag the automatic landing shape handle control because the connected run is pinned.
Public property Static member MayUnjoinRailAndSupports Fillet may cause the supports unjoin with the rail.
Public property Static member MultistoryLevelBelowTopbottomLevel Multistory top level must be above the stair/ramp top and bottom levels.
Public property Static member MultistoryLevelBelowTopbottomLevelError Multistory top level must be above the stair/ramp top and bottom levels.
Public property Static member MultistoryStairDoesntReach The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
Public property Static member MultistoryStairsAutomaticLevelLandingsDeleted Level landings are deleted because the connected stairs have been regenerated.
Public property Static member MultistoryStairsComponentJoinFailure Can't keep elements joined. Avoid converting stairs to skeched-based component in Multistory stairs.
Public property Static member MultistoryStairsHideTopLevelParameter You have set the stair's multistory top level to None, and Revit will remove this parameter, if you want to create a multistory stair, please use Create Multistory Stair feature.
Public property Static member MultistoryStandardStairBottomEndExceedsOrNotReach One of the stairs inside multistory stairs bottom ends exceeds or cannot reach the base elevation of the stair.
Public property Static member MultistoryStandardStairTopEndExceedsOrNotReach One of the stairs inside multistory stairs top ends exceed or cannot reach the top elevation of the stair.
Public property Static member MultusegmentRampRiser Ramp can't have multisegment Riser.
Public property Static member MultusegmentRampRiserError Ramp can't have multisegment Riser.
Public property Static member NoCurvesInRailing Railing Sketch has no Lines.
Public property Static member NoProfileForRail Must specify Profiles for every Rail.
Public property Static member NoRailingsStringer Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
Public property Static member NoRisersInPureMonolithicStairs Monolithic Stairs with zero tread thickness can't have risers
Public property Static member NoRunsRamp Ramp has no Runs. Can't create Ramp.
Public property Static member NoRunsRampError Ramp has no Runs. Can't create Ramp.
Public property Static member NotALineRiserRamp Riser line must be a straight line for Ramps.
Public property Static member NotALineRiserRampError Riser line must be a straight line for Ramps.
Public property Static member NotchThicknessIsLargerThanLandingWarning The notch thickness is larger than landing.
Public property Static member NotEnoughRisers Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
Public property Static member OnlyMonolithicStairs Tread thickness can't be zero for non-monolithic stairs
Public property Static member PartOfRiserLiesOnBoundaryFailure Part of the riser lies on the boundary is not allowed.
Public property Static member PathDoesntJoinToBorderRisersFailure Path doesn't join to border risers is not allowed.
Public property Static member RailCurveTooShort Curve in rail sketch is too short for rail creation and ignored.
Public property Static member RailingBadOffset An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
Public property Static member RailingCurvesNotSplitRamp The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
Public property Static member RailingCurvesNotSplitStairs The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
Public property Static member RailingDoublyConnected Railings hosted on Stairs must form a single, open, connected line.
Public property Static member RailingNotConnected The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
Public property Static member RailPathCloseLoopForExtensionWarning The rail path is closed at the start and end path point for extension creation.
Public property Static member RailPlacedOutsideOfHost Railings are placed completely outside the host. It may change the adjustment of the railing to the host and its vertical position.
Public property Static member RailProfileLowerThanFilletError Fillet cannot be created between rail segment since the radius is lower than the profile size.
Public property Static member RailProfileLowerThanFilletFailure Fillet cannot be created between rail segment since the radius is lower than the profile size.
Public property Static member RailProfileOpen Open Profile Loop can't be used as a Rail Profile
Public property Static member RailTypeChangeInconsistancyWarningWithResetBtn Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
Public property Static member RampDoesntReach The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
Public property Static member RampDoesntReachOffset The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
Public property Static member RampLandingNotCreated Beginning of run coincide with the end of previous run. Landing is not created between runs.
Public property Static member RampRunTooComplex Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
Public property Static member RampStartHigherThanEnd The ramp's base (base level + base offset) must be below its top (top level + top offset).
Public property Static member RiserCurveTooShort Riser curve is too short to create nosing on it.
Public property Static member RiserHeightIsTooSmall Riser height is too small.
Public property Static member RiserIntWithBoundaryMoreThanOnceFailure Riser intersects with boundary more than once.
Public property Static member RisersAtSameLocation The highlighted risers have the same location along the boundary line. Please move one of the two risers.
Public property Static member RiserThicknesssResetToZero Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
Public property Static member RunBottomHigherThanTopFailure The base elevation for the run is higher than the top elevation for the run.
Public property Static member RunBottomUnderStairsBottomFailure Run bottom elevation should not be below the stairs bottom elevation.
Public property Static member RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
Public property Static member RunTopLowerThanBottomFailure The top elevation for the run is lower than the base elevation for the run.
Public property Static member SpiralRunRadiusTooSmallFailure The radius value for the run is too small.
Public property Static member StairIncompleteFailure Stair element is incomplete, not all components are logic connected.
Public property Static member StairsActualRiserHeightGreaterThanMaximumFailure Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
Public property Static member StairsActualRunWidthLessThanMinimumFailure Actual run width is less than minimum run width defined in stairs type.
Public property Static member StairsActualTreadDepthLessThanMinimumFailure Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
Public property Static member StairsAlreadyAttachedToCurrentLevel Mutistory Stairs already have a Stair attaching to this level.
Public property Static member StairsAreUpdatedDueToLevelHeightChange Stair component(s) in the multistory stair are updated due to the level height changes.
Public property Static member StairsAutomaticLandingLayoutFailure Fail to generate the automatic landing layout
Public property Static member StairsAutomaticLandingLayoutWarn Fail to generate the automatic landing layout
Public property Static member StairsBottomEndExceedsOrNotReachWarning Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
Public property Static member StairsCannotExtendToFloorStructureLayerWarning Stairs cannot extend to floor structure layer.
Public property Static member StairsCommonRunGenerateLayoutFailure Fail to get base line thus fail to generate run layout
Public property Static member StairsComponentJoinFailure Can't keep elements joined.
Public property Static member StairsCrossingRisersDisallowedFailure Crossing risers are not allowed
Public property Static member StairsGenericFailure Stairs generic failure
Public property Static member StairsGenericTransformFailure Cannot change base elevation of Stairs
Public property Static member StairsIllegalDesiredNumRisers Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
Public property Static member StairsInMultistoryExceedTopConstraint Stairs in MultistoryStairs after adjusting still exceed the top constraint.
Public property Static member StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Only single boundary case may have riser with its both ends on boundary.
Public property Static member StairsOtherThan2IntsByRiserAndBoundaryFailure More than 2 intersection points between riser segment and boundary encountered
Public property Static member StairsPathPositionResetWarning The stairs path doesn't intersect with riser lines.
Public property Static member StairsRunRunJoinNotAllowedFailure Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
Public property Static member StairsStartHigherThanEnd The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
Public property Static member StairsStringerCannotBeCreated The stairs stringer cannot be created.
Public property Static member StairsSubElementsNotConnectedWarning Stair sub-elements are not connected
Public property Static member StairsSupportOverlapFailure Some supports overlap with others
Public property Static member StairsSupportTooShort A short support is being created.
Public property Static member StairsTopEndExceedsOrNotReachWarning Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
Public property Static member StairsTopLowerThanBaseFailure The top of the Stair is lower than the base of the Stair
Public property Static member StairStringerCantOffset Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
Public property Static member StairsWinderGenLayoutFailure Fail to generate run layout and then cannot make winder run
Public property Static member StairsWinderInvalidParamsFailure Cannot create the winder run because some values for the instance properties cannot be satisfied.
Public property Static member StairsZeroDesiredRisers The number of desired risers for a staircase cannot be 0.
Public property Static member StringerCurvesNotSplitStairs The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
Public property Static member StringerCurveTooShort A piece of boundary is too short to create stringer on it.
Public property Static member TooShortCurveDowngradeGeometry Curve is too short and may downgrade the geometry.
Public property Static member TreadDepthBelowMin The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
Public property Static member TreadDepthFailsEq The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
Public property Static member TreadDepthTooBigFailure The tread depth is too large for the spiral run.
Public property Static member TreadFrontProfileInvalid This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
Public property Static member UnableToCreateMultistoryStairs Unable to create Multistory stairs.
Public property Static member UnexpectedCurveIntersectionFailure Computing curve intersection and find the invalid result.
Public property Static member WinderFilletRadiusTooLargeFailure The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
Public property Static member WinderFirstLegTooShortOrRunWidthTooGreatFailure The first leg of winder run is too short or the runwidth is too great.
Public property Static member WinderGenericError Cannot make winder.
Public property Static member WinderLegIsTooShortFailure A winder leg is too short.
Public property Static member WinderLegsAngleTooGreatOrRunWidthTooSmallFailure The angle between two consecutive legs are too great or the runwidth is too small.
Public property Static member WinderLegTooShortOrRunWidthTooGreatFailure One leg of the winder run is too small or the runwidth is too great.
Public property Static member WinderMinWidthTooLargeFailure The value for Minimum Width on Inside Boundary is too large.
Public property Static member WinderMinWidthTooLargeForParallelTreadsFailure The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
Public property Static member WinderParallelLegsFailure Two consecutive legs are parallel.
Public property Static member WinderParallelTreadsNumberFailure Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
Public property Static member WinderRunCreationFailure The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
Public property Static member WinderRunInsideMinTreadDepthFailure Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
Public property Static member WinderRunInsideWalklineOffsetFailure Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
Public property Static member WinderRunWidthLessThan2TimesMinWidthFailure The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
Public property Static member WinderRunWidthLessThanWalkLineOffsetFailure The value for Run Width is less than two times of value of the inside walkline offset.
Public property Static member WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
Public property Static member WinderRunWidthOrMinWidthOrTooShortFailure The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
Public property Static member WinderSecondLegTooShortOrRunwidthTooGreatFailure The second leg of winder run is too short or the runwidth is too great.
Public property Static member WinderStraightStepsNumberFailure The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
Public property Static member WinderThirdLegTooShortOrRunWidthTooGreatFailure The third leg of winder run is too short or the runwidth is too great.
Public property Static member WinderTooManyEndParallelTreadsOrRunWidthFailure The number of parallel treads at end is too great or the run width is too great.
Public property Static member WinderTooManyParallelTreadsAtEndFailure The number of parallel treads at end is too great.
Public property Static member WinderTooManyParallelTreadsAtHeadFailure The number of parallel treads at start is too great.
Public property Static member WinderTooManyStartParallelTreadsOrRunWidthFailure The number of parallel treads at start is too great or the run width is too great.
Top
See Also