Analytical |
Note: This API is now obsolete.
Checks if curve loop is valid for Analytical Surface.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IsOuterContourValid' method instead.")]
public static bool IsCurveLoopValid(
CurveLoop profile
)
Parameters
- profile CurveLoop
- The curve loop to be checked.
Return Value
BooleanReturns true if curve loop is ok, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |