DistributionSysTypeSet Class


Distribution Sys Type Set Class

A set that contains DistributionSys types.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical DistributionSysTypeSet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DistributionSysTypeSet : APIObject, 
	IEnumerable

The DistributionSysTypeSet type exposes the following members.

Constructors
Name Description
Public method DistributionSysTypeSet Initializes a new instance of the DistributionSysTypeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Size Returns the number of DistributionSys types that are in the set.
Top
Methods
Name Description
Public method Clear Removes every DistributionSys type from the set, rendering it empty.
Public method Contains Tests for the existence of a DistributionSys type within the set.
Public method Erase Removes a specified DistributionSys type from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method Insert Insert the specified DistributionSys type into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Top
See Also