Water Class


Water Class

A static class that provides access to the property names that appear in the Water visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Water

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Water

The Water type exposes the following members.

Properties
Name Description
Public property Static member CommonTintColor The property labeled "Tint Color" from the "Water" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "Water" schema.
Public property Static member WaterBumpAmount The property labeled "Wave Height" from the "Water" schema.
Public property Static member WaterColorByObject The property labeled "Custom Color" from the "Water" schema.
Public property Static member WaterTintColor The property labeled "Custom Color" from the "Water" schema.
Public property Static member WaterTintEnable The property labeled "Color" from the "Water" schema.
Public property Static member WaterType The property labeled "Type" from the "Water" schema.
Top
See Also