DocumentPrinting Event


Controlled Application Document Printing Event

Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting

Value

EventHandler DocumentPrintingEventArgs
Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document. This document-level event precedes the application-level event of the same name.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, Autodesk::Revit::ApplicationServices::Application::ViewPrinting and Autodesk::Revit::ApplicationServices::Application::ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also