Railing Host |
The host of the railing.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: The hostId is not a valid railing host. |
ArgumentNullException | When setting this property: A non-optional argument was null |

If the host will be a Stairs in MultistoryStairs element, use [M:Autodesk.Revit.DB.Architecture.Railing.SetMultistoryStairsPlacementLevels(System.Collections.Generic.ISet`1{Autodesk.Revit.DB.ElementId})] to set the base levels of the stairs where the railing should be placed.
If %hostId% is the id of a Stairs Component (Run or Landing), it means that the Railing will be hosted by the Stairs element but railing adjustment to the stairs will start from the Component. If a stairs id is set as a host, the lowest stairs component below or above the railing sketch will be chosen as the host instead.