IDuctFittingAndAccessoryPressureDropUIServer Interface


IDuct Fitting And Accessory Pressure Drop UIServer Interface

Interface for external servers providing optional UI for duct fitting and duct accessory coefficient calculation.

Namespace: Autodesk.Revit.UI.Mechanical
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IDuctFittingAndAccessoryPressureDropUIServer : IExternalServer

The IDuctFittingAndAccessoryPressureDropUIServer type exposes the following members.

Methods
Name Description
Public method GetDBServerId Returns the Id of the corresponding DB server for which this server provides an optional UI.
Public method ShowSettings Shows the settings UI.
Top
Remarks
This service works with duct fitting and accessory pressure drop service. It provides the settings for the duct fitting and accessory pressure drop server if needed; and it also provides UI for user to input the settings in Revit. A typical way to use the external server can be:
  • Implement a server class that derives from this interface
  • Create a new server object and register it with the service.
See Also