FilterableValueProvider Class


Filterable Value Provider Class

Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterableValueProvider
Autodesk.Revit.DB ParameterValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterableValueProvider : IDisposable

The FilterableValueProvider type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FilterableValueProvider
Public method GetAssociatedGlobalParameterValue Gets a global parameter value associated with a parameter from the given element.
Public method GetDoubleValue Gets a double-precision numeric value from the given element.
Public method GetElementIdValue Gets an ElementId value from the given element.
Public method GetIntegerValue Gets an integer value from the given element.
Public method GetStringValue Gets a string value from the given element.
Public method IsDoubleValueSupported Determines whether the provide can provide a double-precision numeric value for the given element.
Public method IsElementIdValueSupported Determines whether the provide can provide an ElementId value for the given element.
Public method IsIntegerValueSupported Determines whether the provide can provide an integer value for the given element.
Public method IsStringValueSupported Determines whether the provide can provide a string value for the given element.
Top
See Also