ReInsert Method (Definition, Binding)


Binding Map Re Insert(Definition, Binding) Method

Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual bool ReInsert(
	Definition key,
	Binding item
)

Parameters

key Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Return Value

Boolean
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.
See Also