Schedule |
Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- fieldId ScheduleFieldId
- The field ID to check.
Return Value
BooleanTrue if the field ID would create a circular chain of references, false otherwise.

Exception | Condition |
---|---|
ArgumentException | fieldId is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. |
ArgumentNullException | A non-optional argument was null |