Schedule |

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ScheduleSortGroupField type exposes the following members.

Name | Description | |
---|---|---|
![]() | ScheduleSortGroupField | Creates a new ScheduleSortGroupField. |
![]() | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField. |
![]() | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField. |

Name | Description | |
---|---|---|
![]() | FieldId | The ID of the field that the schedule will be sorted or grouped by. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ShowBlankLine | Indicates if an empty row should be displayed between groups. |
![]() | ShowFooter | Indicates if a footer row should be displayed after each group. |
![]() | ShowFooterCount | Indicates if the footer row should display a count of elements in the group. |
![]() | ShowFooterTitle | Indicates if the footer row should display a title. |
![]() | ShowHeader | Indicates if a header row should be displayed before each group. |
![]() | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ScheduleSortGroupField |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

A schedule may be sorted or grouped by one or more of the schedule's fields. The ScheduleSortGroupField class represents one of the fields that the schedule is sorted or grouped by.
Sorting and grouping are related operations. In either case, elements appearing in the schedule are sorted based on their values for the field that the schedule is sorted/grouped by, which automatically causes elements with identical values to be grouped together. By enabling extra header, footer, or blank rows, visual separation between groups can be achieved.
If ScheduleDefinition.IsItemized is false, elements having the same values for all of the fields used for sorting/grouping will be combined onto the same row.
A schedule can be sorted or grouped by data that is not displayed in the schedule by marking the field used for sorting/grouping as hidden using the ScheduleField.IsHidden property.