HybridElementImport Method


Importer IFC Hybrid Element Import Method

Note: This API is now obsolete.

Imports IFC Elements using non-open-source framework.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a later version of Revit. We suggest you use the 'IFCHybridImport' class instead.")]
public IList<ElementId> HybridElementImport(
	Document doc,
	string file
)

Parameters

doc Document
Document into which Import is done.
file String
Full path of the file to import.

Return Value

IList ElementId
Elements imported using non-open-source framework.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also