GenerateInstanceFromTemplate Method


Panel Schedule View Generate Instance From Template Method

Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void GenerateInstanceFromTemplate(
	ElementId templateId
)

Parameters

templateId ElementId
Element id of the template element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also