Filtered |
Applies an ElementOwnerViewFilter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- viewId ElementId
- The view id of the owner view.
Return Value
FilteredElementCollectorA handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Only elements that are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.