ShapeImporterSourceFormat Enumeration


Shape Importer Source Format Enumeration

An enumerated type listing the possible formats supported by the Shapeimporter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ShapeImporterSourceFormat
Members
Member name Value Description
Auto 0 The format of the incoming data will be determined from input file extension.
OBJ 4 The incoming data is in OBJ format (*.obj).
Rhino 2 The incoming data is in Rhino format (*.3dm).
SAT 1 The incoming data is in SAT format (*.sat).
SketchUp 3 The incoming data is in SketchUp format (*.skp).
STEP 11 The incoming data is in STEP format (*.step, *.stp, *.stpz).
STL 5 The incoming data is in STL format (*.stl).
See Also