Create Method (Curve, Curve)


Ruled Surface Create(Curve, Curve) Method

Creates a Surface object coincident with the ruled surface joining two bounded generating curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Surface Create(
	Curve profileCurve1,
	Curve profileCurve2
)

Parameters

profileCurve1 Curve
The first profile curve; must be bounded and non-degenerate.
profileCurve2 Curve
The second profile curve; must be bounded and non-degenerate.

Return Value

Surface
The created surface. Note that this surface may not be of type RuledSurf.
Exceptions
Exception Condition
ArgumentException The input profileCurve1 is not bound. -or- The profileCurve1 is degenerate (its length is too close to zero). -or- The input profileCurve2 is not bound. -or- The profileCurve2 is degenerate (its length is too close to zero).
ArgumentNullException A non-optional argument was null
Remarks
The returned surface may not be of type RuledSurf - this function will create a surface of the simplest possible type (Plane, CylindricalSurface, etc.) that can be used to represent the given ruled surface. Given that the surface may be simplified, this function does not guarantee any particular parameterization of the surface. The curves should be such that a ruled surface whose rulings connect points on the two curves with the same normalized coordinates has no self-intersections or interior singularities.
See Also