ExportLineweightTable Class


Export Lineweight Table Class

A table supporting a mapping of line weights in Revit to line weight names that will be set in the target export format.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportLineweightTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportLineweightTable : IEnumerable<KeyValuePair<ExportLineweightKey, ExportLineweightInfo>>, 
	IDisposable

The ExportLineweightTable type exposes the following members.

Constructors
Name Description
Public method ExportLineweightTable Constructs a new ExportLineweightTable with default settings.
Top
Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Item A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey .
Top
Methods
Name Description
Public method Add Inserts a (key, info) pair into Export line weight table.
Public method Clear Removes all contents stored in Export line weight table.
Public method ContainsKey Checks whether a line weight key exists in the table.
Public method Dispose Releases all resources used by the ExportLineweightTable
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetExportLineweightInfo Gets a copy of the ExportLineweightInfo corresponding to the given ExportLineweightKey.
Public method GetKeys Gets all the keys stored in the map.
Public method GetLineweightTableIterator Returns a ExportLineweightTableIterator that iterates through the collection.
Public method GetValues Returns all the values stored in the map.
Public method Remove Removes the pair (key, info) corresponding to the given ExportLineweightKey.
Top
Remarks

This table is structured as a mapping from ExportLineweightKey to ExportLineweightInfo members. The ExportLineweightKey contains the identification information for the pattern table: the Revit line weight. The ExportLineweightInfo contains the line weight to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportLineweightInfo returned will be a copy of the ExportLineweightInfo from the table. In order to make changes to the ExportLineweightInfo and use those settings during export, set the modified ExportLineweightInfo back into the table using the same key.

See Also