Worksharing |
Creates a new instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- shouldApply Boolean
- True if the settings should be applied, False if they should be set but not applied.
- lineColor Color
- The desired line color, which must be a valid color. Note that the fill color is calculated automatically from the line color so it is not advisable to use white, black, or shades of grey.

Exception | Condition |
---|---|
ArgumentException | The lineColor argument does not represent a valid color. |
ArgumentNullException | A non-optional argument was null |