GetPlacementNumber Method


Adaptive Component Family Utils Get Placement Number Method

Gets Placement number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static int GetPlacementNumber(
	Document doc,
	ElementId refPointId
)

Parameters

doc Document
The Document
refPointId ElementId
The ReferencePoint id

Return Value

Int32
Placement number of the Adaptive Placement Point.
Exceptions
Exception Condition
ArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
ArgumentNullException A non-optional argument was null
See Also