Application New |
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public PointOnEdge NewPointOnEdge(
Reference edgeReference,
PointLocationOnCurve locationOnCurve
)
Parameters
- edgeReference Reference
- The reference whose edge the object will be created on.
- locationOnCurve PointLocationOnCurve
- The location on the edge.
Return Value
PointOnEdgeIf creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument edgeReference or locationOnCurve is . |