FindInserts Method


Host Object Find Inserts Method

Gets the ids of the instances inserted into this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ElementId> FindInserts(
	bool addRectOpenings,
	bool includeShadows,
	bool includeEmbeddedWalls,
	bool includeSharedEmbeddedInserts
)

Parameters

addRectOpenings Boolean
True if rectangular openings should be included in the return.
includeShadows Boolean
True if shadows should be included in the return.
includeEmbeddedWalls Boolean
True if embedded walls should be included in the return.
includeSharedEmbeddedInserts Boolean
True if shared embedded inserts should be included in the return.

Return Value

IList ElementId
All the insertable instances' ids.
See Also