Autodesk.Revit.Attributes Namespace


Autodesk. Revit. Attributes Namespace

Classes
Class Description
Public class JournalingAttribute The custom journaling attribute to control the journaling behavior of the external command.
Public class RegenerationAttribute The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Public class TransactionAttribute The custom transaction attribute to control the transaction behavior of the external command.
Enumerations
Enumeration Description
Public enumeration JournalingMode All journaling modes supported by Revit external commands.
Public enumeration RegenerationOption All regeneration options supported by Revit external commands and external applications.
Public enumeration TransactionMode All transaction modes supported by Revit external commands.