Autodesk.Revit.DB.PointClouds Namespace


Autodesk. Revit. DB. Point Clouds Namespace

Classes
Class Description
Public class PointCloudColorSettings The color settings which are applied to a PointCloudInstance element, or one of its scans.
Public class PointCloudEngineRegistry This class supports registration of custom Point Cloud Engines in a Revit session.
Public class Code example PointCloudFilter A class used to describe the criteria an application desires when obtaining members of a point cloud.
Public class PointCloudFilterFactory A factory class for creating point cloud filters.
Public class PointCloudFilterUtils Utilities specific to point cloud filters.
Public class PointCloudOverrides Graphic overrides that are stored by a view to be applied to a PointCloudInstance element, or a scan within the element.
Public class PointCloudOverrideSettings The graphic override settings for one PointCloudInstance element or one of its scans.
Public class PointCollection A class that represents a set of points created and returned by Revit in response to a query.
Public class PointIterator A class used to iterate individual points in a PointCollection.
Structures
Structure Description
Public structure CloudPoint Represents a point obtained from a Point cloud.
Interfaces
Interface Description
Public interface IPointCloudAccess An interface that provides functionality for working with an individual Point Cloud.
Public interface IPointCloudEngine An interface that controls the behavior of the link from Revit to a custom Point Cloud Engine.
Public interface IPointSetIterator An interface that Revit will call when iterating through sets of points on the engine.
Enumerations
Enumeration Description
Public enumeration PointCloudColorEncoding The color encodings supported by Revit point clouds.