VisibleInViewFilter Constructor (Document, ElementId, Boolean)


Visible In View Filter(Document, Element Id, Boolean) Constructor

Constructs a new instance of a VisibleInViewFilter, with the option to pass all non-visible elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public VisibleInViewFilter(
	Document document,
	ElementId viewId,
	bool inverted
)

Parameters

document Document
The document that owns the view.
viewId ElementId
The view id.
inverted Boolean
True if the filter should match all elements not visible in the given view.
Exceptions
Exception Condition
ArgumentException viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
ArgumentNullException A non-optional argument was null
See Also