PrintParameters Class


Print Parameters Class

An object that contains settings used for printing the document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB PrintParameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PrintParameters : APIObject

The PrintParameters type exposes the following members.

Properties
Name Description
Public property ColorDepth The color depth type.
Public property HiddenLineViews The hidden line views type.
Public property HideCropBoundaries Indicates whether to hide crop boundaries when printing.
Public property HideReforWorkPlanes Indicates whether to hide reference/work planes when printing.
Public property HideScopeBoxes Indicates whether to hide scope boxes when printing.
Public property HideUnreferencedViewTags Indicates whether to hide unreferenced view tags when printing.
Public property MarginType The print margin type.
Public property MaskCoincidentLines Indicates whether to mask coincident lines when printing.
Public property OriginOffsetX The User defined X value of offset from left bottom corner. Unit is feet.
Public property OriginOffsetY The User defined Y value of offset from left bottom corner. Unit is feet.
Public property PageOrientation The Page Orientation of the Print Setting.
Public property PaperPlacement The paper placement type.
Public property PaperSize The page size.
Public property PaperSource The page source.
Public property RasterQuality The raster quality type.
Public property ReplaceHalftoneWithThinLines Indicates whether to replace halftone with thin lines when printing.
Public property UserDefinedMarginX Obsolete.
The User defined X value of offset from left bottom corner. Unit is inch.
Public property UserDefinedMarginY Obsolete.
The User defined Y value of offset from left bottom corner. Unit is inch.
Public property ViewLinksinBlue Indicates whether to view links in blue when printing.
Public property Zoom The zoom value to a percentage of the original size.
Public property ZoomType The zoom type.
Top
Methods
Name Description
Top
See Also