OverrideServiceButtonExclusion Method


Fabrication Service Override Service Button Exclusion Method

Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void OverrideServiceButtonExclusion(
	int paletteIndex,
	int buttonIndex,
	bool exclude
)

Parameters

paletteIndex Int32
The index of the service palette to exclude the service button from.
buttonIndex Int32
The index of the service button to exclude.
exclude Boolean
Pass true to exclude from being used by Route and Fill or Design to Fabrication.
Exceptions
Exception Condition
ArgumentOutOfRangeException The index paletteIndex is not larger or equal to 0 and less than PaletteCount.
See Also