NamingCategoryId Property


Assembly Instance Naming Category Id Property

Id of the category that drives the default naming scheme for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId NamingCategoryId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
ArgumentNullException When setting this property: A non-optional argument was null
See Also