ConditionType Enumeration


Condition Type Enumeration

An enumerated type listing all the possible condition types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ConditionType
Members
Member name Value Description
Cooled 1 Condition Type is Cooled.
Heated 0 Condition Type is Heated.
HeatedAndCooled 2 Condition Type is HeatedAndCooled.
NaturallyVentedOnly 5 Condition Type is NaturallyVentedOnly.
NoOfConditionTypes 6 Condition Type is NoOfConditionTypes.
Unconditioned 3 Condition Type is Unconditioned.
Vented 4 Condition Type is Vented.
See Also