UnpostFailure Method


Document Unpost Failure Method

Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UnpostFailure(
	FailureMessageKey messageKey
)

Parameters

messageKey FailureMessageKey
The key of the FailureMessage to be deleted.
Exceptions
Exception Condition
ArgumentException messageKey is invalid
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist anymore and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.
See Also