Document Combine |
Combine a set of combinable elements into a geometry combination.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- members CombinableElementArray
- A list of combinable elements to be combined.
Return Value
GeomCombinationIf successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument is . |
ArgumentException | Thrown when members contains less than two elements. Thrown when members contains elements. |
InvalidOperationException | Thrown when creation of the combination failed. |

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.