ZoneEquipmentData Class


Zone Equipment Data Class

Represents the data and parameters of analytical zone equipment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical ZoneEquipmentData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ZoneEquipmentData : IDisposable

The ZoneEquipmentData type exposes the following members.

Properties
Name Description
Public property AirSystemId The air system used for this zone equipment, if applicable.
Public property ChilledWaterLoopId The chilled water loop used for the chilled water option of cooling coil.
Public property CondenserWaterLoopId The condenser water loop used for the direction expansion water cooled option of cooling coil.
Public property CoolingCoilType The type of cooling coil. Note this property change would reset the chilled water loop.
Public property EquipmentBehavior The behavior of how zone equipment is allocated with assigned spaces.
Public property EquipmentType The type of zone equipment. Note this property would reset other properties.
Public property HeatingCoilType The type of heating coil. Note this property change would reset the hot water loop.
Public property HotWaterLoopId The water loop element id for the hot-water heating coil.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property VRFLoopId The Varible Refrigerant Flow loop for the VRF fan coil equipment type.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ZoneEquipmentData
Public method IsDataCompleted Is the required data completed for this zone equipment?
Top
See Also