AlignmentStationLabel Class


Alignment Station Label Class

Represents an object which provides access to a specialized Revit annotation element used for labeling Alignment stations.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Infrastructure AlignmentStationLabel

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AlignmentStationLabel

The AlignmentStationLabel type exposes the following members.

Properties
Name Description
Public property AlignmentId The ElementId of the Alignment on which the SpotDimension is placed.
Public property Element The underlying SpotDimension element.
Public property Station The alignment station at which the SpotDimension is placed.
Top
Methods
Name Description
Public method Static member Create Creates an AlignmentStationLabel object along with its underlying SpotDimension element. Returns null if element creation fails.
Public method Static member CreateRecommendedTypeForSet Creates an element type recommended for alignment label sets and returns its ElementId.
Public method Static member CreateSet Creates a collection of AlignmentStationLabel objects along with their underlying SpotDimension elements.
Public method Static member Get Returns an AlignmentStationLabel object for the given element.
Public method Static member GetAlignmentStationLabels(Alignment) Returns all alignment station labels placed on the given alignment.
Public method Static member GetAlignmentStationLabels(Alignment, ElementId) Returns all alignment station labels placed on the given alignment in the given view.
Public method Static member IsRecommendedTypeForSet Checks if the element type is recommended for alignment labels in sets.
Public method IsValid Checks if this object is a valid alignment station label.
Public method Static member IsValid(Element) Checks if the element is a valid alignment station label.
Public method Static member IsValidType Checks if the type is a valid alignment station label type.
Top
Remarks
The element is a SpotDimension . The element's category is OST_AlignmentStationLabels or, if in a set of labels, OST_AlignmentStationLabelSets . The element's type is a SpotDimensionType with DimensionStyleType equal to AlignmentStationLabel . The element's Origin is a point on the tessellated representation of an alignment. To get the precise point on the alignment's curve, use GetPointAtStation(Double) with input obtained from Station .
See Also