AppendItemFromCurves Method


Rebar Container Append Item From Curves Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RebarContainerItem AppendItemFromCurves(
	RebarStyle style,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ normal,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	bool useExistingShapeIfPossible,
	bool createNewShape
)

Parameters

style RebarStyle
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
normal XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
useExistingShapeIfPossible Boolean
createNewShape Boolean

Return Value

RebarContainerItem
See Also