PointCloudColorSettings Class


Point Cloud Color Settings Class

The color settings which are applied to a PointCloudInstance element, or one of its scans.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.PointClouds PointCloudColorSettings

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointCloudColorSettings : IDisposable

The PointCloudColorSettings type exposes the following members.

Constructors
Name Description
Public method PointCloudColorSettings Constructs color settings object with default colors.
Public method PointCloudColorSettings(PointCloudColorMode) Constructs color settings object with default color for given color mode.
Public method PointCloudColorSettings(PointCloudColorSettings) Constructs a copy of source object.
Public method PointCloudColorSettings(Color, Color) Constructs color settings object from given colors.
Top
Properties
Name Description
Public property Color1 Color 1
Public property Color2 Color 2
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Assign Assigns values of the source settings to this object.
Public method Dispose Releases all resources used by the PointCloudColorSettings
Public method IsEqual Check if the contents of two settings are equal.
Top
Remarks
For different color modes (PointCloudColorMode), the color settings mean different things:
  • for single color, color1 means the display color
  • for other modes (intensity, elevation), color1 and color2 form a gradient from min to max
  • for no overrides and normals, color1 and color2 are not used
See Also