RebarSpliceRules Class


Rebar Splice Rules Class

Describes the rules for splicing Rebar.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarSpliceRules

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarSpliceRules : IDisposable

The RebarSpliceRules type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MaximumBarLength Identifies the maximum bar length. The default value is 12 meters if the document units are in Metric System, or 40 feet if the units are in Imperial System.
Public property MinimumBarLength Identifies the minimum bar length. The default value is 1 meter if the document units are in Metric System, or 3 feet if the units are in Imperial System.
Public property RunOutPosition Identifies the run-out position. The default value is RebarSpliceByRulesRunOutPosition.End.
Top
Methods
Name Description
Public method Static member Create Creates a new instance of RebarSpliceRules with the default options.
Public method Dispose Releases all resources used by the RebarSpliceRules
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetMaximumAndMinimumBarLength Sets the maximum and minimum bar length.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also