GetWindowOrSkylightConstructionType Method


Conceptual Construction Type Get Window Or Skylight Construction Type Method

Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetWindowOrSkylightConstructionType(
	Document ccda,
	ConceptualConstructionWindowSkylightType typeEnum
)

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The enum is invalid for ConceptualConstructionWindowSkylightType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also