IFCOpeningData Class


IFCOpening Data Class

A class that contains opening data including extrusion data, opening solids and opening element id.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCOpeningData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCOpeningData : IDisposable

The IFCOpeningData type exposes the following members.

Properties
Name Description
Public property IsRecess Trus if it is a recess, false if it is an opening.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OpeningElementId The opening element id.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCOpeningData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetExtrusionData Gets extrusion data.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetOpeningSolids Gets opening solids.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also