Structural |
Defines parameters for hot rolled structural sections.

System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
More
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
More
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The StructuralSectionHotRolled type exposes the following members.

Name | Description | |
---|---|---|
![]() | FlangeThickness | Flange Thickness. |
![]() | FlangeThicknessLocation | Flange Thickness Location. |
![]() | WebFillet | Web Fillet - fillet radius between web and flange. |
![]() | WebThickness | Web Thickness. |
![]() | WebThicknessLocation | Web Thickness Location. |

Name | Description | |
---|---|---|


System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralI
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralU
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralW
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionIWideFlange
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionHotRolled
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralI
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralT
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralU
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralW
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionIWideFlange