ConnectionValidationWarning Class


Connection Validation Warning Class

Contains information about a specific connection validation problem.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ConnectionValidationWarning

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConnectionValidationWarning : IDisposable

The ConnectionValidationWarning type exposes the following members.

Constructors
Name Description
Public method ConnectionValidationWarning Constructor.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Reason Enumeration for reason of warning.
Public property Resolution Enumeration for resolution that was applied.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ConnectionValidationWarning
Public method GetParts Get ElementIds of affected parts.
Top
See Also