PartMakerMethodToDivideVolumes Class


Part Maker Method To Divide Volumes Class

By-References dividing strategy used by PartMaker element. TODO_REFACTOR("LegacyMechanismOfMovingElements") returns true if - the Host Elements are not floors or walls - OR - the Host Elements that are referenced by this PartMaker are floors or walls - transformation has already been applied on those Host Elements
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PartMakerMethodToDivideVolumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PartMakerMethodToDivideVolumes : IDisposable

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties
Name Description
Public property DivisionGap The gap which is created between matching profiles of parts.
Public property DivisionPatternMirror Whether pattern defined by the division rule should be mirrored before application Mirroring is similar to changing indices of u-const gridlines.
Public property DivisionRotationAngle Angle by which both u- and v- gridlines of the division are rotated with respect to the natural u/v-const directions of the sketch plane.
Public property DivisionRuleId Id of the 'DivisionRule' which is used to augment the cutting sketch.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ProfileFlipAcross True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property ProfileFlipAlong True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property ProfileMatch Determines how two profiles match.
Public property ProfileOffset The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property ProfileType The id of the profile family applied to boundaries between parts.
Public property UConstDivisionIndent Indentation for the application of division rule's pattern across u-const gridlines (i.e., similar to changing indices of u-const gridlines).
Public property VConstDivisionIndent Indentation for the application of division rule's pattern across v-const gridlines (i.e., similar to changing indices of v-const gridlines).
Top
Methods
Name Description
Public method AddIntersectingReference Adds intersecting reference with an offset.
Public method AreElementsValidIntersectingReferences(ICollection ElementId )
Public method Static member AreElementsValidIntersectingReferences(Document, ICollection ElementId )
Public method CanBeDivisionProfile(ElementId) Checks whether a family defines a profile which can be used by this method.
Public method Static member CanBeDivisionProfile(ElementId, Document) Checks whether a family defines a profile which can be used by this method.
Public method Dispose Releases all resources used by the PartMakerMethodToDivideVolumes
Public method GetOffsetForIntersectingReference Gets offset for the intersecting reference.
Public method GetPlaneOfSketch Gets the plane of the sketch.
Public method GetSketchCurves
Public method GetSplitRefsOffsets Returns offsets for plane-defining splitters.
Public method IsElementValidIntersectingReference(ElementId) Identifies if the provided member is valid.
Public method Static member IsElementValidIntersectingReference(Document, ElementId) Identifies if the provided member is valid.
Public method Static member IsValidSketchPlane Identifies if provided sketch plane is valid.
Public method RemoveIntersectingReference Removed intersecting reference.
Public method SetOffsetForIntersectingReference Sets offset for the intersecting reference.
Public method UsesReference Identifies if the PartMaker uses the intersecting reference.
Top
See Also