IPoint |
Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

int ReadPoints(
PointCloudFilter rFilter,
ElementId viewId,
IntPtr buffer,
int nBufferSize
)
Parameters
- rFilter PointCloudFilter
- The filter used to process cloud points and determine which ones lie with the target volume.
- viewId ElementId
- The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.
- buffer IntPtr
- Memory buffer into which the points should be written. The buffer was allocated by Revit and it is guaranteed to be valid for the duration of the call.
- nBufferSize Int32
- The maximum number of CloudPoint objects that may be copied into the buffer.
Return Value
Int32The actual number of CloudPoint objects placed in the buffer (can be less than the length of the buffer). If there are no points available that match the filter criteria, return 0.