DefaultOpenFromCloudCallback Class


Default Open From Cloud Callback Class

A default callback that may be used to control Revit's behavior when opening a model.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DefaultOpenFromCloudCallback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DefaultOpenFromCloudCallback : IOpenFromCloudCallback, 
	IDisposable

The DefaultOpenFromCloudCallback type exposes the following members.

Constructors
Name Description
Public method DefaultOpenFromCloudCallback Create a default open callback. Open latest by default for all scenarios.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DefaultOpenFromCloudCallback
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method OnOpenConflict A method called when the conflict is happen during the model opening.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also