GetAllGlobalParameters Method


Global Parameters Manager Get All Global Parameters Method

Returns all global parameters available in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ISet<ElementId> GetAllGlobalParameters(
	Document document
)

Parameters

document Document
The document containing the global parameters

Return Value

ISet ElementId
A collection of Element Ids of global parameter elements.
Exceptions
Exception Condition
ArgumentException Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families.
ArgumentNullException A non-optional argument was null
See Also