AlignmentStationLabelOptions Class


Alignment Station Label Options Class

Represents an object containing options for creating an AlignmentStationLabel .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Infrastructure AlignmentStationLabelOptions

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AlignmentStationLabelOptions

The AlignmentStationLabelOptions type exposes the following members.

Constructors
Name Description
Public method AlignmentStationLabelOptions Creates an object with default values.
Top
Properties
Name Description
Public property HasLeader Specifies if the label will have a leader. The default value is true.
Public property LeaderEnd Specifies the leader end point, in model coordinates. The default value is null. When null, the end point will be the same as the Origin point, driven by the Station value.
Public property LeaderShoulder Specifies the leader shoulder point, in model coordinates. The default value is null. When null, the shoulder point will be the same as the Origin point, driven by the Station value.
Public property Station Specifies the station at which the label will be placed, in Revit internal model units (standard Imperial feet). The station determines the location of the label's origin: Origin by setting it to the closest point on the alignment geometry which corresponds to this station.
Public property TypeId Specifies the ElementId of the label type. The default value is InvalidElementId. In this case, the default type id for alignment station labels in the document is used.
Top
Methods
Name Description
Top
See Also