GetRoomAtPoint Method (XYZ)


Document Get Room At Point(XYZ) Method

Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Room GetRoomAtPoint(
	XYZ point
)

Parameters

point XYZ
Point to be checked.

Return Value

Room
The room containing the point.
Exceptions
Exception Condition
ArgumentNullException Thrown when the point is .
ArgumentException Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.
Remarks
Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns .
See Also