IsValidUsage Method


Direct Shape Is Valid Usage Method

Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidUsage(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The geometry to check.

Return Value

Boolean
True if the usage is permitted.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also