Family |
Adds a new sweep form to the family document, using a path of curve elements.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public Sweep NewSweep(
bool isSolid,
CurveArray path,
SketchPlane pathPlane,
SweepProfile profile,
int profileLocationCurveIndex,
ProfilePlaneLocation profilePlaneLocation
)
Parameters
- isSolid Boolean
- Indicates if the Sweep is Solid or Void.
- path CurveArray
- The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
- pathPlane SketchPlane
- The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be for 3D paths or for 2D paths where the path should not reference an existing face.
- profile SweepProfile
- The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
- profileLocationCurveIndex Int32
- The index of the path curves. The curve upon which the profile plane will be determined.
- profilePlaneLocation ProfilePlaneLocation
- The location on the profileLocationCurve where the profile plane will be determined.
Return Value
SweepIf creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentException | Thrown when the input argument-path-is or empty. |
ArgumentNullException | Thrown when the input argument-profile-is . |
ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds. |
ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration. |
InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where sweeps cannot be created. |
InvalidOperationException | Thrown when the creation failed. |

This method creates a sweep in a family document. The sweep will trace the profile along the path.